Validic Support Ticketing System Experiencing Delays
Incident Report for Validic V1
Resolved
Desk.com has resolved the system processing issue they experienced earlier today. The Validic support ticketing system is now operating normally.
Posted Mar 25, 2015 - 13:21 EDT
Identified
Desk.com, the ticketing system Validic uses to manage support cases, is experiencing some delays in email processing. Due to the issue, you may see some delays in our response to support cases while this issue is begin addressed. For critical issues that need immediate attention, please email ben.clark@validic.com directly.
Posted Mar 25, 2015 - 10:58 EDT