Announcement: Data Made Available on our Legacy API restricted to 180 days
Incident Report for Validic V1
Resolved
Validic has updated the Legacy API to reduce the available historical data to a rolling 180-day window. Calls with a beginning and end date that are both outside this window will fail. Calls with a beginning date outside this window, but an end date inside the window will be successful, but will only contain records from the last 180 days. Clients who request records older than 180 days are encouraged to migrate to our Inform API, which allows access to up to 365 days of user data.
Posted Feb 03, 2020 - 10:24 EST
Update
This is a final reminder that starting tomorrow, February 1st, 2020, Validic will reduce the available historical data on our Legacy API to a rolling 180-day window. Calls with a beginning and end date that are both outside this window will fail. Calls with a beginning date outside this window, but an end date inside the window will be successful, but will only contain records from the last 180 days. Clients who request records older than 180 days are encouraged to migrate to our Inform API, which allows access to up to 365 days of user data.
Posted Jan 31, 2020 - 15:16 EST
Update
This is a reminder that beginning February 1st, 2020, Validic will reduce the available historical data on our Legacy API to a rolling 180-day window. Calls with a beginning and end date that are both outside this window will fail. Calls with a beginning date outside this window, but an end date inside the window will be successful, but will only contain records from the last 180 days. Clients who request records older than 180 days are encouraged to migrate to our Inform API, which allows access to up to 365 days of user data.
Posted Jan 28, 2020 - 15:48 EST
Identified
Earlier this year, Validic announced that we will continue to support our Legacy API indefinitely, allowing our clients to migrate to our new Inform API at their convenience. To enable the legacy platform to continue running efficiently, beginning February 1st, 2020, Validic will limit the amount of data made available on our Legacy API to 180 days. In the past, we’ve allowed our customers to request several years of data through the API, though our analysis shows that queries older than 180 days are rare. Clients who request records older than 180 days are encouraged to migrate to our Inform API, which allows queries of up to 365 days.

At the time of this change, we will reduce the available historical data on our Legacy API to a rolling 180-day window. Calls with a beginning and end date that are both outside this window will fail. Calls with a beginning date outside this window, but an end date inside the window will be successful, but will only contain records from the last 180 days. We suggest developers review their applications and make any needed revisions to prepare for this change.

If you have any questions regarding this, please contact support@validic.com.

Thank you,
Validic Technical Support
Posted Dec 02, 2019 - 09:15 EST
This incident affected: API.