Fitbit Data Delays
Incident Report for Validic V1
Resolved
The delivery of Fitbit data has returned to expected times.
Posted Oct 14, 2021 - 12:14 EDT
Monitoring
Validic is continuing to monitor an ongoing issue regarding data delays with Fitbit.

We will provide updates here when they are available.
Posted Oct 14, 2021 - 09:15 EDT
This incident affected: Fitbit.